System Compatibility

Test your browser here
https://www.ssllabs.com/ssltest/viewMyClient.html

Internet browser compatibility guidelines

As we enhance our security to align with industry requirements, you will need to verify if your operating systems (OS) and browsers support TLS 1.2 and upgrade if necessary.
If you do not have a compatible OS version or browser, you will get a connection warning or error when attempting use our shop. Run the test by clicking the link to SSL LABS above.
A new tab will open and it will display the results. Look at the top result of Protocol Support. The expected result is “Your user agent has good protocol support.”

The following table lists the most common internet browsers. The table lists each browser with the compatibility of TLSv1.2 for recent versions.

Browser

TLS 1.2 Compatibility Notes

Microsoft EdgeCompatible by default
Desktop and mobile versionsCompatible by default
Microsoft Internet Explorer (IE)Review the Internet Explorer Support for TLSv1.2 article for detailed information and instructions.
Desktop and mobile IE version 11Compatible by default
Desktop IE versions 9 and 10Windows Vista and older operating systems, such as Windows XP, are not compatible with TLS 1.2 encryption.
Desktop IE versions 8 and belowNot compatible or stable with TLS 1.2 encryption.
Mozilla FirefoxCompatible with the most recent, stable version
Firefox 27 and higherCompatible by default
Firefox 23 to 26Capable, but not by default.
Firefox 22 and belowNot compatible with TLS 1.2 or higher encryption.
Google ChromeCompatible with the most recent, stable version
Google Chrome 38 and higherCompatible by default
Google Chrome 22 to 37Capable when run in Windows XP SP3, Vista, or newer (desktop), OS X 10.6 (Snow Leopard) or newer (desktop), or Android 2.3 (Gingerbread) or newer (mobile)
Google Chrome 21 and belowNot compatible with TLS 1.2 encryption.
Google Android OS Browser
Android 6.0 (Marshmellow) and higherCompatible by default
Android 5.0 (Lollipop) and higherCompatible by default
Android 4.4 (KitKat) to 4.4.4Capable, but not by default.
Android 4.3 (Jelly Bean) and belowNot compatible with TLS 1.2  encryption.
Apple Safari
Desktop Safari versions 7 and higher for OS X 10.9 (Mavericks) and higherCompatible by default
Apple Desktop should be OSX/MacOS 10.9+
Desktop Safari versions 6 and below for OS X 10.8 (Mountain Lion) and belowNot compatible with TLS 1.2 encryption.
Mobile Safari versions 5 and higher for iOS 5 and higherCompatible by default
Apple Mobile should be iOS5+
Mobile Safari for iOS 4 and belowNot compatible with TLS 1.2 encryption.

 


Visit Shop